It is currently Mon Apr 24, 2017 12:40 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: IP Address used on server
PostPosted: Mon Jan 28, 2013 1:01 pm 

Joined: Mon Sep 17, 2012 7:59 am
Posts: 3
Hi all,

I'm trying to get a openl2tp setup working in combination with ppp and ippool.

At the moment I've got a connection from a Windows 7 machine going to a Linux server; the server is configured with a pool of available IP addresses for remote connections. I've setup /etc/ippool.conf like so:
Code:
pool create pool_name=default
pool address add pool_name=default first_addr=10.1.1.1 num_addrs=10 netmask=255.255.0.0
pool address reserve pool_name=default first_addr=10.1.1.1 num_addrs=1

I've then started the ippool daemon and set the configuration like so:
Code:
$ /usr/sbin/ippoold
$ /usr/bin/ippoolconfig config restore file=/etc/ippool.conf

After that is running I start off openl2tp using the configuration file:
Code:
tunnel profile modify profile_name=default \
   our_udp_port=1701

ppp profile modify profile_name=default \
        auth_eap=no \
   auth_pap=no \
   auth_none=yes \
   auth_chap=yes \
   auth_mschapv1=yes \
   auth_mschapv2=yes \
   local_ipaddr=10.1.1.1 \
   dns_ipaddr_pri=10.10.10.10 \
   ip_pool_name=default

This is run using the following command:
Code:
$ /usr/sbin/openl2tpd -c /etc/openl2tpd.conf  -p ipsec.so

After this I'm able to connect via the Windows 7 machine, which gets the address 10.1.1.2 which I can see in both Windows and via ifconfig on the Linux server.

Now my problem is that the local IP Address is getting picked up by the Linux box instead of the ppp IP address.

My question is how can I get the address taken from the ippool to be visible to my box instead of the Windows address?

At the moment I'm using iptables to do various things to incoming traffic from the 10.1.1.0 network, which ofcourse isn't working as the address it see's is the Windows address.

Any points etc would be greatly appreciated as this is rapidly causing headaches :)

Thanks


Top
 Profile  
 
 Post subject: Re: IP Address used on server
PostPosted: Fri Feb 15, 2013 9:11 am 
Site Admin

Joined: Sun Jul 27, 2008 1:39 pm
Posts: 122
fishadder wrote:
Now my problem is that the local IP Address is getting picked up by the Linux box instead of the ppp IP address.

My question is how can I get the address taken from the ippool to be visible to my box instead of the Windows address?

At the moment I'm using iptables to do various things to incoming traffic from the 10.1.1.0 network, which ofcourse isn't working as the address it see's is the Windows address

This sounds like a routing setup problem.
What is on the 10.1.1.0 network? I notice this is the subnet you are using for your IP address pool.
Try adding the following to your ppp profile:
use_as_default_route=yes


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group