openl2tp.org
http://forums.openl2tp.org/

Error loading openl2tp.so with pppd
http://forums.openl2tp.org/viewtopic.php?f=3&t=122
Page 1 of 1

Author:  dahool [ Thu Jul 04, 2013 11:00 am ]
Post subject:  Error loading openl2tp.so with pppd

When i try to make a ppp session:
pppd debug kdebug 7 noipdefault sync nodetach local noauth noaccomp nopcomp nobsdcomp nodeflate nopredictor1 novj novjccomp noendpoint nomp noproxyarp plugin pppol2tp.so plugin openl2tp.so pppol2tp 19 pppol2tp_lns_mode pppol2tp_tunnel_id 34364 pppol2tp_session_id 62219 pppol2tp_debug_mask 15

I get the following error:
pppd: /usr/lib/pppd/2.4.5/openl2tp.so: undefined symbol: doing_multilink
pppd: Couldn't load plugin openl2tp.so

Tunnel establishes ok, with the following command:
pppd 10.3.1.1:10.3.1.2 debug kdebug 7 noipdefault sync nodetach local noauth noaccomp nopcomp nobsdcomp nodeflate nopredictor1 novj novjccomp noendpoint nomp noproxyarp plugin pppol2tp.so plugin openl2tp.so pppol2tp 19 pppol2tp_tunnel_id 60957 pppol2tp_session_id 45929 pppol2tp_debug_mask 15

I used example from the page. System is Openwrt.

Versions:
Openl2tp 1.8
pppd-2.4.5

If anyone has any ideas, how to fix this.

Thanks,
dahool

Author:  jchapman [ Mon Jul 21, 2014 7:35 am ]
Post subject:  Re: Error loading openl2tp.so with pppd

dahool wrote:
When i try to make a ppp session:
pppd debug kdebug 7 noipdefault sync nodetach local noauth noaccomp nopcomp nobsdcomp nodeflate nopredictor1 novj novjccomp noendpoint nomp noproxyarp plugin pppol2tp.so plugin openl2tp.so pppol2tp 19 pppol2tp_lns_mode pppol2tp_tunnel_id 34364 pppol2tp_session_id 62219 pppol2tp_debug_mask 15

I get the following error:
pppd: /usr/lib/pppd/2.4.5/openl2tp.so: undefined symbol: doing_multilink
pppd: Couldn't load plugin openl2tp.so

Tunnel establishes ok, with the following command:
pppd 10.3.1.1:10.3.1.2 debug kdebug 7 noipdefault sync nodetach local noauth noaccomp nopcomp nobsdcomp nodeflate nopredictor1 novj novjccomp noendpoint nomp noproxyarp plugin pppol2tp.so plugin openl2tp.so pppol2tp 19 pppol2tp_tunnel_id 60957 pppol2tp_session_id 45929 pppol2tp_debug_mask 15

I used example from the page. System is Openwrt.

Versions:
Openl2tp 1.8
pppd-2.4.5

If anyone has any ideas, how to fix this.

Thanks,
dahool

It it likely that specifying local and remote IP addresses in the working case bypasses the information exchange between pppd and openl2tpd using openl2tp.so to establish the IP address of the connection. The core issue is that openl2tp.so isn't compiled correctly against the actual version of pppd being used on the target OpenWRT system. Check the pppd USE_MULTILINK build option. This is hard-coded in OpenL2TP to match the setting in the pppd distribution. Make sure it matches how pppd is configured for OpenWRT.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/