It is currently Thu Dec 14, 2017 11:05 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Re: tunnel
PostPosted: Thu Mar 26, 2015 8:51 am 
Site Admin

Joined: Sun Jul 27, 2008 1:39 pm
Posts: 122
abeha wrote:
Also the l2tpethx interface is also gone.

However, when I attempt to recreate the tunnel, using the exact same command as I initially did, this is the result:

# ip l2tp add tunnel tunnel_id 90 peer_tunnel_id 1 udp_sport 5016 udp_dport 5017 encap udp local 172.16.0.1 remote 172.16.0.10
RTNETLINK answers: Operation not permitted

Changing the tunnel id will not have any effect. However, if I change the port numbers or the remote IP address, I am able to create the tunnel.

What is lingering after I delete a tunnel that is preventing me from creating it again? How can I get rid of whatever is lingering?

Or even better, why does the tunnel stop passing traffic in the first place?

This isn't an OpenL2TP problem - you are using static L2TPv3 tunnels.
I suggest use the kernel's l2tp debugfs to see what state the kernel has about the tunnel.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group