openl2tp.org
http://forums.openl2tp.org/

openl2tp on Debian Etch
http://forums.openl2tp.org/viewtopic.php?f=3&t=7
Page 1 of 1

Author:  gr0mit [ Wed Nov 26, 2008 11:14 am ]
Post subject:  openl2tp on Debian Etch

Hi Chaps
Am trying to get openl2tp running on my Etch box with 2.6.18-5-k7 kernel.

Trying to install the openl2tp_1.6-1_i386.deb package and I get errors with dependancy of libc6 needing > 2.7-1

So i tried to compile from source and got an error Kernel does not have L2TP Support - Aborting. DOH!

Any pointers please?

Many thanks
Rgds
Tim Robinson
Basingstoke, UK

Author:  gr0mit [ Wed Nov 26, 2008 12:00 pm ]
Post subject:  Re: openl2tp on Debian Etch

Hi
Updated kernel to
uname -a
Linux voice 2.6.24-etchnhalf.1-686 #1 SMP Mon Oct 13 07:27:05 UTC 2008 i686 GNU/Linux

and am still getting
voice:/usr/src/openl2tp-1.6# make
Kernel does not have L2TP support. Aborting
make: *** [check] Error 1
voice:/usr/src/openl2tp-1.6#

Any more advice?

Rgds
Tim

Author:  jchapman [ Sun Nov 30, 2008 10:48 pm ]
Post subject:  Re: openl2tp on Debian Etch

gr0mit wrote:
Hi
Updated kernel to
uname -a
Linux voice 2.6.24-etchnhalf.1-686 #1 SMP Mon Oct 13 07:27:05 UTC 2008 i686 GNU/Linux

and am still getting
voice:/usr/src/openl2tp-1.6# make
Kernel does not have L2TP support. Aborting
make: *** [check] Error 1
voice:/usr/src/openl2tp-1.6#

Any more advice?

Rgds
Tim

Does that kernel have CONFIG_PPPOL2TP configured?

Does KERNEL_SRCDIR point to the configured kernel sources?

Author:  jchapman [ Tue May 18, 2010 12:09 pm ]
Post subject:  Re: openl2tp on Debian Etch

spide21 wrote:
The same problem happened to me on FC11, when it tries to compile it says "Kernel does not have L2TP support. Aborting
make: *** [check] Error 1"

Can you help me?

Thanks in advanced.

Carlos.

The makefile looks for $(KERNEL_SRCDIR)/include/linux/pppol2tp.h. So you need the kernel headers installed that match your kernel, or point $(KERNEL_SRCDIR) at another configured kernel source tree. The debian package should include the kernel headers as a dependency. Are you building from the tarball?

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/